PHP 7'ye Geçmeniz İçin 4 Neden

PHP 7'ye Geçmeniz İçin 4 Neden

Joomla! projesi, gelecek yıl Joomla! 4 ile birlikte PHP 7'ye geçiş zorunluluğuna ilişkin farkındalık yaratmak istiyor. Joomla! 4 ve PHP 7 mükemmel bir eşleşme olacak..

Bu bildiride belirtildiği üzere, Joomla! 4'ün çalıştırılması için PHP 7 gerekecektir. Çoğu sunucu firması paketlerinde PHP 7'yi zaten sunmaktadır ve PHP sürümünüzü değiştirmek oldukça kolaydır. PHP'yi yükseltmeyi beklememeniz için size 4 neden sunalım.

PHP 7 Daha İyidir

Elbette söylemesi kolay, ancak PHP 7 aslında web sitenizi iki kat daha hızlı (PHP 5'e kıyasla) çalıştıran ve % 50 daha iyi bir bellek tüketimi sağlayan bir performans geliştirmesine sahip. Ayrıca PHP 7 daha güvenlidir.

Joomla! 4 Harika Olacak

Joomla! 4'de, hem kullanıcılar hem de geliştiriciler için büyük gelişmeler olacaktır. Temizlenen bir kod, yenilenen bir çerçeve, harika yeni özellikler ve çok daha fazlası. Önyükleme 4 çekirdekte uygulanacak, 2 yeni şablon (önyüz ve arka uç) olacak, yeni medya yöneticisi birçok kişi tarafından sevilecektir.

Joomla! 4 şuan için geliştirme aşamasında olup, 2018 yılının ikinci yarısı hazır olması bekleniyor. Müthiş özellikler listesi lansmandan önce de devam edecek ve duyurulacaktır.

Yenilenen Framework

Joomla! 4'le birlikte gelen yenilenen Framework (sürüm 2.0) bazı önemli gelişmelere sahiptir. Veritabanı API'sı, önemli bir güvenlik geliştirmesi olan hazır ifadeleri doğal olarak destekleyecektir. Şifrelenmiş verileri saklama artık daha modüler bir bileşen ile mümkün olacaktır. Komut satırı araçları, yeni Konsol bileşeni sayesinde daha iyi ve daha güvenli olabilir.

Tüm özelliklerin listesi için yol haritasını ziyaret edin .

Daha Güvenli ve Destekleniyor

PHP 5.6'dan eski sürümler artık güvenlik düzeltmeleri için desteklenmiyor. PHP 5.3'te bazı büyük güvenlik açıkları bulunursa, kimse bunu düzeltmeyecek ve siteniz güvenlik açığından etkilenecek. En yeni sürümü kullanarak, bu olası sorunların halledileceğini her zaman öğreneceksiniz ve güncellemeler var olduğunda çok hızlı bir şekilde sunulacaktır.

PHP 7 son büyük sürüm olduğundan, Joomla! 4 web sitenizin 2025'e kadar kolayca yayınlanabilmesi için uzun süreli (küçük yayınlar dahil) desteklenecektir.

Peki'ya Yükseltemiyorsam?

Hatırlanması gereken önemli bir husus, Joomla! 3.9 'un piyasaya sürülmesinden iki yıl sonra daha destekleneceğidir. Bu, Joomla! 3 sitenizi 2020'ye kadar konforlu bir şekilde çalıştırabileceğiniz anlamına gelir; ancak, Joomla! 4'ün tüm harika özelliklerini ve avantajlarını gözden kaçıracağınız anlamına gelir.

Diyelim ki, sunucu firmanız şimdiye kadar PHP 7' yi desteklemiyordu, dürüst olmak gerekirse iyi bir hosting firması aramanız gerekecektir.

Sizler de Joomla! alt yapısına sahip web sitelerinizde PHP 7 için bir an evvel gerekli adımları atmalısınız. Konu ile ilgili Joomla! proje ekibinden M.Babker şu açıklamayı yaptı..

"Yeni jenerasyon Joomla! 'yı en iyi jenerasyon haline getirmeye kararlıyız ve kullanıcılarımızın PHP 7'yi benimseyerek yüksek kalitede ürünü sunmamıza yardımcı olacağına inanıyoruz." 

M. Babker

Önerilen Makaleler