Teknik Gereksinimleri

Joomla! popüler bir CMS sistemi olmasına rağmen, gerekli teknik gereksinim ihtiyaçları karşılanmadığı takdir de, kimi sunucular da zaman, zaman sorun çıkarma ihtimali olduğunu görebiliriz. Bu sebeple Joomla! kurulumunu yapmadan önce, ihtiyaç duyulan "teknik gereksinimleri" kontrol etmenizde fayda vardır. Peki, Joomla! 3.x sürümünde ne gibi teknik gereksinimlere ihtiyaç vardır?

Desteklenen Yazılım Gereksinimleri

Joomla! 3.x İçin Gereksinimler

YazılımÖnerilenMinumumDaha fazla bilgi
PHP
(Magic Quotes GPC off)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Desteklenen Veritabanları:
MySQL
(InnoDB desteği gereklidir)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Desteklenen Web Sunucuları:
Apache
(with mod_mysql, mod_xml, and mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS
7 7 https://www.iis.net

Desteklenmeyen Yazılım Gereksinimleri

Joomla! 1.6, 1.7 ve 2.5 İçin Gereksinimler - 31 Aralık 2014'te destek sona erdi

YazılımÖnerilenMinumumDaha fazla bilgi
PHP 5.6 5.2.4 https://secure.php.net
Desteklenen Veritabanları:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server
10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Desteklenen Web Sunucuları:
Apache
(with mod_mysql, mod_xml, and mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS
7 7 https://www.iis.net

Joomla! 1.5 İçin Gereksinimler

31 Aralık 2012'de destek sona erdi

YazılımÖnerilenMinumumDaha fazla bilgi
PHP
5.3 4.3.10 https://secure.php.net
Desteklenen Veritabanları:
MySQL 4.1.x + 3.23 https://www.mysql.com
Desteklenen Web Sunucuları:
Apache
(with mod_mysql, mod_xml, and mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS
7 6 https://www.iis.net

Joomla! 1.0 İçin Gereksinimler

22 Temmuz 2009'da destek sona erdi

YazılımÖnerilenMinumumDaha fazla bilgi
PHP
5.3 4.2 https://secure.php.net
Desteklenen Veritabanları:
MySQL 4.1.x + 3.23 https://www.mysql.com
Desteklenen Web Sunucuları:
Apache
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS
7 6 https://www.iis.net

DİPNOTLAR

1: PHP 5.3.1 sürümü 3.0 ve 3.2 için gereklidir. Joomla! 3.3'de ise minumum PHP 5.3.10 sürümü gerekli olup, Joomla! 3.5 sürümünün PHP 7 'yi desteklemesi ile birlikte, Joomla! 3.5 ve daha üst sürümler için PHP 7 tercih edilebilir.

2: Joomla! 3.5, MySQL'in "utf8mb4" karakter kümesi desteği varsayılan olarak eklenir ve bunu destekleyen sunucular tarafından varsayılan olarak kullanılır.

3: SEO URL'lerini kullanmak için, Apache mod_rewrite uzantısının yüklü olması gerekir.

4: PHP 4.3.9, 4.4.2 veya 5.0.4 kullanmayın. Bu sürümlerin kurulumu esnasında bazı hataların olduğu bilinmekte. PHP 4.4 için Zend Optimizer 2.5.10'da ciddi hatalar olduğu belirtilmiş, sunucu firmanızdan daha yeni bir sürüme yükseltmesini isteyin. Joomla! 1.5.15 ve sonraki sürümler PHP 5.3 ile uyumludur, OpenID kitaplığının ise henüz PHP 5.3 ile uyumlu olduğunu söylemek mümkün değil.

5: Joomla! 2.5 sürümü için Microsoft SQL Server desteği eklenmiştir, Joomla! 1.6 ve 1.7'nin bu desteği yoktur.

6: Microsoft IIS için aşağıdakilere ihtiyaç duyabilirsiniz.

- PHP 5.2 - Kurulum talimatları
- MySQL 5.1 - Yükleme talimatları
- Microsoft URL Rewrite Modülü - Yalnızca SEO URL'leri için gereklidir. Daha fazla bilgi için buraya tıklayın . ISAPI kullanma hakkında bilgi için, buraya tıklayın .
- FastCGI - IIS6 indirmek için . IIS7 indirmek için buraya tıklayın.

Microsoft IIS kullanıyorsanız daha fazla yardım için Joomla! IIS forumunu ziyaret ediniz .

logo.png
Soru, görüş yada teknik destek
ihtiyacınız için iletişim kısmından
irtibat kurabilirsiniz.

Bizi Takip Edin!

Joomla!® name is used under a limited license from Open Source Matters in the United States and other countries.
JoomlaVia.com is not affiliated with or endorsed by Open Source Matters or the Joomla! Project.
Copyright © Joomla! Via 2018. Her Hakkı Saklıdır.