Joomla! 3x İçin Teknik Gereksinimler

Joomla! 3.x İçin Teknik Gereksinimler

Joomla! popüler bir CMS sistemi olmasına rağmen, kimi sunucular da zaman,zaman düzgün bir şekilde çalışmadığını görebiliriz. Bunun sebeplerinden birisi de "teknik gereksinimler" dir, peki Joomla! 3x sürümünde ne gibi teknik gereksinimlere ihtiyaç vardır?

Bugün ki yazımızda sizlere Joomla'nın sunucular'da rahatlıkla ve düzgün bir şekilde çalışması için, ne gibi teknik gereksinimlere ihtiyacı olduğunu aktaralım. Joomla! 3x sürümü için hangi teknik gereksinimlere ihtiyaç olduğunu ve daha fazlasını aşağıdaki tablo da görebilirsiniz.

YazılımÖnerilenMinimumDaha Fazla Bilgi
PHP
Zlib Sıkıştırma Desteği, XML Desteği, INI Ayrıştırıcı Desteği, JSON Desteği, Mcrypt Desteği, MB Dil = Varsayılan)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Desteklenen Veritabanları:
MySQL
(InnoDB desteği gerekli)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Desteklenen Web Sunucuları:
Apache
(with mod_mysql, mod_xml, and mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS
7 7 https://www.iis.net

Dipnotlar

1: PHP 5.3.1 sürümü 3.0 ve 3.2 için gereklidir. Joomla! 3.3'de ise minumum PHP 5.3.10 sürümü gerekli olup, Joomla! 3.5 sürümünün PHP 7 'yi desteklemesi ile birlikte, Joomla! 3.5 ve daha üst sürümler için PHP 7 tercih edilebilir.

2: Joomla! 3.5, MySQL'in "utf8mb4" karakter kümesi desteği varsayılan olarak eklenir ve bunu destekleyen sunucular tarafından varsayılan olarak kullanılır.

3: SEO URL'lerini kullanmak için, Apache mod_rewrite uzantısının yüklü olması gerekir.

4: PHP 4.3.9, 4.4.2 veya 5.0.4 kullanmayın. Bu sürümlerin kurulumu esnasında bazı hataların olduğu bilinmekte. PHP 4.4 için Zend Optimizer 2.5.10'da ciddi hatalar olduğu belirtilmiş, sunucu firmanızdan daha yeni bir sürüme yükseltmesini isteyin. Joomla! 1.5.15 ve sonraki sürümler PHP 5.3 ile uyumludur, OpenID kitaplığının ise henüz PHP 5.3 ile uyumlu olduğunu söylemek mümkün değil.

5: Joomla! 2.5 sürümü için Microsoft SQL Server desteği eklenmiştir, Joomla! 1.6 ve 1.7'nin bu desteği yoktur.

6: Microsoft IIS için aşağıdakilere ihtiyaç duyabilirsiniz.

Comments powered by CComment

Önerilen Makaleler