Joomla! Güvenlik Haberleri

Joomla! 3.7.0'da SQL Injection Güvenlik Açığı

Kullanıcı Oyu: 5 / 5

Yıldız etkinYıldız etkinYıldız etkinYıldız etkinYıldız etkin
 

Joomla! 3.7.0 sürümü bildiğiniz üzere 25 Nisan'da yayınlanmıştı, bu doğrultuda bizler de kullanıcıların bir an önce web sitelerini yeni sürüme güncellemeleri konusunda bilgilendirme yapmıştık.

Joomla! 3.7.0 sürümünün yayınlanmasından kısa bir zaman sonra, bir güvenlik açığı tespit edilmiş ve Joomla! güvenlik ekibi çalışmalarına başlamıştı. Yapılan çalışmalar sonucunda 17 Mayıs Çarşamba günü Joomla! 3.7.1 yama sürümü yayınlandı... Bugün ki yazımızda, Joomla! 3.7.0 sürümünde yer alan SQL Injection güvenlik açığına ilişkin bilgileri sizlerle paylaşacağız.

Sucuri Firewall (WAF) için yapılan düzenli araştırma denetimleri sırasında, Joomla! 3.7.0'ı etkileyen bir SQL Injection güvenlik açığı tespit edilmiştir. Güvenlik açığından yararlanmak kolay olduğu gibi, mağdurun sitesinde ayrıcalıklı bir hesaba ihtiyaç olmadığı da belirtilmekte.

SQL Injection Nedir?

Web uygulamalarında bir çok işlem için kullanıcıdan alınan veri ile dinamik SQL cümlecikleri oluşturulur. Mesela "SELECT * FROM Products" örnek SQL cümleciği basit şekilde veritabanından web uygulamasına tüm ürünleri döndürecektir. Bu SQL cümlecikleri oluşturulurken araya sıkıştırılan herhangi bir meta-karakter SQL Injection'a neden olabilir. Kaynak: ferruh.mavituna.com

Joomla! Web Siteniz Risk Altında mı?

Güvenlik açığı, Joomla! 3.7.0 sürümü ile birlikte gelen yeni bir bileşen olan "com_fields" tarafından oluşturuldu. Bu sürümü kullanırsanız, etkilenirsiniz ve en kısa zamanda web sitenizi güncellemelisiniz. Bu güvenlik açığından etkilenen bileşene herkes tarafından erişilme ihtimali vardır... Bu durum sitenizi ziyaret eden herhangi kötü niyetli bir kişinin sorundan yararlanabileceği anlamına geliyor.

SQL Injection saldırılarının niteliği göz önüne alındığında, bir saldırganın zarar verebileceği birçok yol vardır - örnek, sızıntı yapan kişi parola bilgileri ve oturum açmış olan bir kullanıcının oturumunu ele geçirebilir, ayrıca veritabanı içeriğini kendisine aktarabilir. Bir yönetici oturumu ele geçirilirse web sitesine tamamen zarar verilebilinir.

Teknik Detaylar

Kamuya dönük "com_fields" bileşeni, aynı adı taşıyan idari yan bileşenden bazı kodları ödünç alır. Bunu yapması garip birşey gibi gelebilir, ancak çok pratik bir amaca hizmet eder; bu, sıfırdan tekrar kod yazmak yerine diğer taraf için yazılmış genel kodun yeniden kullanılmasına olanak tanır.

Bu güvenlik açığından yararlanabilmek için, bir saldırganın yapması gereken şey, iç içe geçmiş SQL sorgularını enjekte etmek için URL'ye uygun parametreleri eklemektir. Teknik detaylar hakkında daha fazla bilgi almak için SUCURİ Blog'da yer alan yazıyı okuyabilirsiniz.

Sonuç Olarak

Henüz yapmadıysanız, mümkün olan en kısa sürede web sitenizi Joomla! 3.7.1 sürümüne güncelleyin!... Bu, savunmasız bir siteyi tehlikeye atmak için farklı yollarla kötüye kullanılabilecek ciddi bir güvenlik açığıdır. Joomla! sitenizin saldırıya uğradığına inanıyorsanız, sucuri.net tarafından ücretsiz olarak verilen temizleme rehberini takip edebilirsiniz .

NOT: Bu yazı sucuri.net/blog da yer alan Marc-Alexandre Montpas tarafından yazılmış "SQL Injection Vulnerability in Joomla! 3.7" başlıklı yazı kaynak alınarak bir kısmı Türkçe'ye çevrilmiştir.